StateRestore not working with SearchPanes

StateRestore not working with SearchPanes

edknitteledknittel Posts: 2Questions: 1Answers: 0

Link to test case: http://live.datatables.net/badaweqe/
Debugger code (debug.datatables.net): enovuf
Error messages shown: No error messages shown.
Description of problem: When I apply advanced filtering using the SearchPanes extension I can create a new State using the StateRestore Plugin but I am unable load the saved state.
Steps to reproduce:
1. Select "London" from the Office SearchPane
2. Click the "Create State" button
3. In the "Create New State" modal save the state as "London" and click the "Create" button
4. Click the "Clear All" link at the top of the screen or click on "London" in the Office SearchPane to remove the filtering
5. Click on the "Saved States" button
6. Click on "London" from the dropdown list
Expected Results: All rows with London listed as an Office should be visible while all other rows should be filtered out.

Is it just not possible to use the StateRestore plugin with SearchPanes or am I doing something wrong?

This question has an accepted answers - jump to answer

Answers

  • colincolin Posts: 14,526Questions: 1Answers: 2,482
    Answer ✓

    That's correct, that is a known issue, please see the compatibility chart here. Once it is resolved, we'll add examples for StateRestore and SearchPanes.

    Colin

  • edknitteledknittel Posts: 2Questions: 1Answers: 0

    @Colin thank you for the quick response. My apologies for not reviewing the compatibility chart before posting my question. Since I posted my question I switched to using the SearchBuilder which is compatible with the StateRestore extension.

  • colincolin Posts: 14,526Questions: 1Answers: 2,482

    Perfect, we do hope to address that issue before too long, so please keep an eye out for the releases.

    Colin

Sign In or Register to comment.