Problem with Editor 2.0.9 and bootstrap 5

Problem with Editor 2.0.9 and bootstrap 5

nattee115nattee115 Posts: 2Questions: 0Answers: 0

I am trying to upgrade my Editor from 1.9.2 to 2.0.9 which is just recently released. I also bump my bootstrap to version 5 at the same time.

However, I always get this error Uncaught ReferenceError: Editor is not defined when importing editor.bootstrap5.min.js. When I check the official demo at https://editor.datatables.net/examples/styling/bootstrap5.html, it also shows the same error as follow.

Uncaught ReferenceError: Editor is not defined
    <anonymous> https://editor.datatables.net/extensions/Editor/js/editor.bootstrap5.min.js:1
    <anonymous> https://editor.datatables.net/extensions/Editor/js/editor.bootstrap5.min.js:1
    <anonymous> https://editor.datatables.net/extensions/Editor/js/editor.bootstrap5.min.js:1

Should I go back to 2.0.8? Please advice.

Replies

  • allanallan Posts: 57,300Questions: 1Answers: 9,127 Site admin
    edited September 14

    Yuck! Sorry about that. I've just fixed it (problem with the packaging scripts I've been working on) and the updated file is on the site now (you may need to go a cache refresh).

    I'll be doing a 2.0.10 release probably tomorrow to address this.

    Thanks for flagging it up,
    Allan

  • nattee115nattee115 Posts: 2Questions: 0Answers: 0

    Thank you for a quick reply.

  • sharpspoonsharpspoon Posts: 6Questions: 2Answers: 0
    edited September 24

    I am getting the following error:
    "Can't find variable: Editor"
    within the bootstrap5 file. Would this be related?

  • kthorngrenkthorngren Posts: 17,294Questions: 25Answers: 4,109

    @sharpspoon Possibly. Are you using Editor 2.0.9 ? If so you should be able to download 2.0.10 from the Editor download page.

    Kevin

  • allanallan Posts: 57,300Questions: 1Answers: 9,127 Site admin

    Yes spot on. The 2.0.10 release was specifically to fix that error in 2.0.9. Apologies.

    Allan

Sign In or Register to comment.