Save State is not keeping the start parameter

Save State is not keeping the start parameter

jordonshawjordonshaw Posts: 23Questions: 9Answers: 0

I have a very unique issue. In Safari, everything works exactly as expected. Let's say I go to page 5 in my Datatable, in go into the details of a record on page 5, which navigates me away from that datatable. When I come back to my datatable, I'm exactly where I left off, just as I would expect with savestate turned on.

Now, I do the same thing in Google Chrome and when I navigate back to my datatable, I'm at page 1, not the page that I page I was on when I navigated away. My first thought was that savestate just wasn't working for some reason in Chrome; however, this is where it gets tricky. If I sort on a column that isn't the default sort, then navigate away, when I come back to my DT, it is still sorted on the last column I sorted and not the default. So the sorting in savestate seems to stay in Chrome. The only thing that doesn't seem to be sticking is the "start" in the savestate to tell my DT what page to start on.

Unfortunately, this is behind a login within an application, so I can't share it here; however, I'm wondering if anyone has any potential solutions or if this is a known issue?

Thanks in advance,
Jordon

Answers

  • kthorngrenkthorngren Posts: 16,400Questions: 25Answers: 3,891

    This test case works in Chrome:
    http://live.datatables.net/yoyupifo/1/edit

    Are there things you are doing with stateSaveParams or stateLoad Params that might cause the issue? See if you an update my test case to replicate the problem.

    Kevin

  • jordonshawjordonshaw Posts: 23Questions: 9Answers: 0

    I can't replicate it in your table and I'm not using those values; however, I just realized that it does seem to be related to something I'm doing. So, I think I got it from here.

    Thanks so much for your help!

Sign In or Register to comment.