I have an issue with data not being shown when using searchpanes

I have an issue with data not being shown when using searchpanes

StrWebStrWeb Posts: 6Questions: 1Answers: 0

Link to test case: https://live.datatables.net/fesagilu/1/edit?html,js,output

Description of problem: While using searchpanes, if I navigate past the first page then apply a filter that produces results shorter than the length of the current result set, I get a bug where I only see the the follow message with not results.
For example, I have a table with 100 rows. The first page shows rows 1 - 10, the second page shows 11 - 20, ect. I go to the second page. I then use the searchpanes and click on a filter that will show less than 5 results. When I do that, no results will show at all until I either change the result length or until I click the first page on the pagniation.

Showing 21 to 1 of 1 entries (filtered from 57 total entries)

Is there a fix to this issue?

Answers

  • allanallan Posts: 60,962Questions: 1Answers: 9,940 Site admin

    Nasty - thanks for letting me know about this. It looks like it is present still in the nightly as well.

    We'll be doing a draw() somewhere that isn't resetting the paging on the filter change which is incorrect. I'll look into that and post back which I've got a fix (which will probably be Monday now).

    Allan

  • StrWebStrWeb Posts: 6Questions: 1Answers: 0

    Thank you very much

  • StrWebStrWeb Posts: 6Questions: 1Answers: 0

    Hello @allan Do you have an update on this item?

  • allanallan Posts: 60,962Questions: 1Answers: 9,940 Site admin

    Apologies, I've gotten side tracked with other things. I'll look into this very soon.

    Allan

  • StrWebStrWeb Posts: 6Questions: 1Answers: 0

    Thank you

  • allanallan Posts: 60,962Questions: 1Answers: 9,940 Site admin

    Fix committed here. It will be in the nightly shortly.

    Sorry about that!
    Allan

  • StrWebStrWeb Posts: 6Questions: 1Answers: 0

    Hello Allan, I'm still having the same issue while using the nightly build.

    Screenshot 1

    Screenshot 2

  • StrWebStrWeb Posts: 6Questions: 1Answers: 0

    Hello @allen,

    I'm still having the same issue

Sign In or Register to comment.