How do I fix this error : $.fn.dataTable.Editor is not a constructor

How do I fix this error : $.fn.dataTable.Editor is not a constructor

cunchucunchu Posts: 2Questions: 1Answers: 0
edited April 14 in Editor

I have purchased the Editor license, but the JS in the downloaded installation package cannot be used. The error is as follows:
Uncaught TypeError: $.fn.dataTable.Editor is not a constructor
at HTMLDocument.<anonymous> ((索引):84:22)
at mightThrow (jquery-3.5.1.js:3762:29)
at process (jquery-3.5.1.js:3830:12)

Answers

  • cunchucunchu Posts: 2Questions: 1Answers: 0
    edited April 14

    I changed the JS reference to the one described below, and the page is displayed and used normally. So, I wonder if there is a problem with the downloaded installation package?

    <script src="http://desa.antsgsm.com/ants/libs/Editor-2.0.4/js/dataTables.editor.js" ></script>

  • allanallan Posts: 57,236Questions: 1Answers: 9,113 Site admin

    I'm not aware of an issue with the download package. Could you give me a link to your page showing the issue and I'll debug it please?

    Thanks,
    Allan

Sign In or Register to comment.