Only date popup for datetime field, and where'd my sort arrows go?

Only date popup for datetime field, and where'd my sort arrows go?

SkrockiSkrocki Posts: 21Questions: 9Answers: 0

I have tried referring to this https://editor.datatables.net/examples/dates/datetime.html among many other references here and on stackoverflow. I've even tried to use my xdsoft picker that I'm using on every other date or datetime, but I can't get that to work even with the date only, nevermind datetime. Am I missing some syntax or styling? Or something else altogether?

Also, at some point I lost the arrows in my column headers to indicate sorting. I read some stuff that seemed to indicate 2 examples where there was a problem with the image directory, but I don't even see the arrows in my image directory. Any ideas on that one?

Thanks for any help or suggestions!

Steve

This question has accepted answers - jump to:

Answers

  • allanallan Posts: 57,236Questions: 1Answers: 9,113 Site admin

    I can't get that to work even with the date only, nevermind datetime. Am I missing some syntax or styling? Or something else altogether?

    Without a test case, I'm afraid it is impossible to say. Are you getting an error or something else? My guess is that you've not loaded the Moment library and specified a date / time format?

    Also, at some point I lost the arrows in my column headers to indicate sorting

    You'd need to give me a link to a page showing the issue. However, the icons can get found here.

    Allan

  • SkrockiSkrocki Posts: 21Questions: 9Answers: 0

    What a douche. I spend days building a sample site balancing open code with security and preparing sensible questions WITH a test case…then forget to include the link!

    https://sandbox.claimpenguin.com/public/dataTable/claimtracker.php

    Sorry about that.

  • allanallan Posts: 57,236Questions: 1Answers: 9,113 Site admin
    Answer ✓

    Heh - easy done :)

    There is something funny going on here... The image URL is being loaded and the server is responding with a 200 OK, but there are zero bytes coming back.

    This is the URL: https://sandbox.claimpenguin.com/components/DataTables/DataTables-1.11.4/images/sort_asc.png .

    Do you have terminal access to that box? Could you ls -l the images directory there and show me the output?

    Thanks,
    Allan

  • SkrockiSkrocki Posts: 21Questions: 9Answers: 0

    I do have terminal access and the images all showed 0 bytes. I reloaded them and it works perfectly. Thank you!

    What do you think about the datetime picker only showing dates?

  • allanallan Posts: 57,236Questions: 1Answers: 9,113 Site admin
    Answer ✓
    Format: 'M/D/YYYY',
    

    is wrong - it should be format. Example available here.

    Allan

  • SkrockiSkrocki Posts: 21Questions: 9Answers: 0
    edited April 13

    Works perf. Thank you. I thought I'd tried it with that function in there before, but did not have the caps correct in format.

Sign In or Register to comment.