Keytable, jEditable and cells width

Keytable, jEditable and cells width

jgaiottojgaiotto Posts: 4Questions: 0Answers: 0
edited April 2012 in KeyTable
Hi all, it's been a long time I use datatables now, and I got to say it is a pretty good plugin, very useful to me.

Recently I made a little Excel-like treasury software through Datatables, Keytable and jEditable.

Technically, it works very well, but here is my problem :

When Keytable is disabled, the table is nice and sweet : it can adapt to every screen resolution (from 1024*768 to whatever) - because, yes, here, we still have people working with 15" inches screens and 1024 resolutions...

Anyway. When Keytable is enabled, it kind of "fix" the cells' width, to a pretty big one though, and it greatly grows the table's one. So obviously, it is ok with big resolution like mine, but for people with 1024 resolutions, the table exceeds their screen...

I looked to the live code with Google Chrome and IE9 and the cells have their width set to 150px. Even when nocell is focused.

I deleted the jEditable capacity just to see if it came from there, and the problem persists. I conclude the issue comes from Keytable.

So I tried to look to the Keytable code because but I can't find anything. (I particularly looked to the _fnInit function because the issue is here just after the page loaded).

I also tried to set the width through the sWidth property, or forcing it in the THs of the THEAD, or in th TDs, but it didn't work.

I use the version 1.8.1 of Datatables and the 1.1.7 of Keytable.

Can anyone help please ? Thank you !


  • jgaiottojgaiotto Posts: 4Questions: 0Answers: 0
    I just updated the Datatables version to 1.9.1 and I still have the issue.
  • jgaiottojgaiotto Posts: 4Questions: 0Answers: 0
    Nevermind, problem solved. Thx.
  • yoderyoder Posts: 1Questions: 0Answers: 0
    What did you do? I have a similar issue (jEditable input is way to wide, when using KeyTables and DataTable)
  • jgaiottojgaiotto Posts: 4Questions: 0Answers: 0
    edited May 2012
    I had inputs of type text in the tfoot, and I forgot to set their width, so by default, they were 150px wide... I set them to 90px and magically... It worked
This discussion has been closed.