Editor Select2 bug with too many fields

Editor Select2 bug with too many fields

rdueckrdueck Posts: 12Questions: 2Answers: 0

Link to test case: https://data2.mcmillan-mcgee.com/test2.php
Debugger code (debug.datatables.net): iverek
Error messages shown:
Description of problem: With too many fields in Editor, one of which is the id, and one of which has type "select2", two bugs appear with the select:
- the search field does not accept input
- the select dropdown does not close if I exit the edit panel with "ESC" (clicking the close gadget works fine)
The number of fields that triggers the issue seems to vary, with 12 fields being the lowest number, where earlier the problem showed up at the 18th field. I've tried to reproduce this issue at http://live.datatables.net/viferade/1/edit, but it works properly there. The only difference I could see is that live.datatables.net apparently uses Editor 2.0.8. I tried both 2.0.0 and 2.0.10 from my own servers, both of which exhibited the bug.

Answers

  • allanallan Posts: 61,635Questions: 1Answers: 10,092 Site admin

    I'm not seeing these two issues on Firefox at the moment. I'll try it again on Chrome when I get into the office in the morning.

    Allan

  • rdueckrdueck Posts: 12Questions: 2Answers: 0

    I'm on macOS 13.1. It works in Chrome 107 and Safari 6.2, but not in Firefox 109.0.1. I guess that points to a Firefox bug, but http://live.datatables.net/viferade/1/edit manages to avoid the issue.

  • allanallan Posts: 61,635Questions: 1Answers: 10,092 Site admin

    Sorry - I got side tracked with things yesterday!

    You first link appears to work in Firefox 108.0.1 (Linux), but it only has a single select2 field. I'll try upgrading to 109 and see what happens...

    Allan

  • allanallan Posts: 61,635Questions: 1Answers: 10,092 Site admin

    109.0 and it appears to be okay. I'll see if I can borrow my wife's Mac later on :)

    Allan

  • rdueckrdueck Posts: 12Questions: 2Answers: 0

    Still not working in Firefox 110.0.1 on macOS 13.2.1.

  • rdueckrdueck Posts: 12Questions: 2Answers: 0

    I've updated my test case to use Editor 2.1.1, still the same problem.

Sign In or Register to comment.