Trying to view the editor examples on my server- can't get past this error. Please Help

Trying to view the editor examples on my server- can't get past this error. Please Help

SeaMonkeySeaMonkey Posts: 2Questions: 1Answers: 0
edited May 2019 in Free community support

Trying to view the Editor Examples on my server

Link:
http://www.dashboard.snydersmeats.com/EDITOR/examples/

Error:

DataTables warning: table id=example - An error occurred while connecting to the database 'db755786004'. The error reported by the server was: SQLSTATE[HY000] [1045] Access denied for user 'db755786004'@'74.208.57.172' (using password: YES)

Answers

  • SeaMonkeySeaMonkey Posts: 2Questions: 1Answers: 0

    Update:

    Fixed the above issue- Now I am Having this Error:

    {"error":"An error occurred while connecting to the database ''. The error reported by the server was: SQLSTATE[HY000] [2002] No such file or directory"}

  • colincolin Posts: 12,877Questions: 0Answers: 2,198

    Hi @SeaMonkey ,

    I just tried your link and all appears to be working as expected, so guessing you've resolved that issue?

    Cheers,

    Colin

  • andrewtiteandrewtite Posts: 1Questions: 0Answers: 0

    How did you solve this. I'm stuck on the same thing. I'm running my database on an AWS RDS instance

  • allanallan Posts: 54,881Questions: 1Answers: 8,601 Site admin

    Which error - access denied or no such file or directory? The first suggests the user hasn't been setup for access with the credentials used, while the second suggests the database might not exist.

    Allan

  • davykiashdavykiash Posts: 35Questions: 13Answers: 1

    @andrewtite Did you solve your problem? I am facing the same exact issue on my AWS RDS instance.

  • allanallan Posts: 54,881Questions: 1Answers: 8,601 Site admin

    @davykiash - did you install the Editor demo SQL and also does config.php have the access credentials for your AWS RDS?

    Allan

  • davykiashdavykiash Posts: 35Questions: 13Answers: 1

    @allan I have added the credentials though they change during runtime. It's strange that on my local development machine [Windows] it works without the need for credentials but when I deploy the same code to production [Linux] that issue emerges.

    I am good now. Thanks.

  • isaaczhaoisaaczhao Posts: 1Questions: 0Answers: 0

    update lib/config.php with following info:

    • Database user / pass
      */
      $sql_details = array(
      "type" => "Mysql", // Database type: "Mysql", "Postgres", "Sqlserver", "Sq
      "user" => "", // Database user name
      "pass" => "", // Database password
      "host" => "", // Database host
      "port" => "", // Database connection port (can be left empty for defa
      "db" => "", // Database name
      "dsn" => "", // PHP DSN extra information. Set as charset=utf8mb4
      "pdoAttr" => array() // PHP PDO attributes array. See the PHP documentation
      );
  • sochvidsochvid Posts: 1Questions: 0Answers: 0
    edited October 4

    I'm stuck on the same thing. I'm running my database on an AWS RDS instance . .

  • colincolin Posts: 12,877Questions: 0Answers: 2,198

    Have you tried the two things Allan suggested earlier in this thread?

    did you install the Editor demo SQL and also does config.php have the access credentials for your AWS RDS?

    Colin

Sign In or Register to comment.